Skip to content
Selecting swc_core

Selecting the version

Currently, the Wasm plugins are not backwards compatible. So you need to select an appropriate version of swc_core for your plugin.

Thie page documents the version of swc_core you can use for each runtime.

Note for next.js


If you use a version in a range of the title, the Wasm plugin will work for the runtimes written in the body.


We modified AST definitions because of Explicit Resource Management proposal (opens in a new tab), which is stage 3.

  • @swc/core@1.3.58 ~
  • next@v13.4.3-canary.2 ~


We enabled strict mode of rkyv and updated wasmer to v3.

  • @swc/core@1.3.49 ~ @swc/core@1.3.57
  • v13.3.1-canary.12 ~ next@v13.4.3-canary.1

v0.72.4 ~ v0.74.6

We updated rkyv to v0.7.40 and the bug is now fixed.

  • @swc/core@1.3.44 ~ @swc/core@1.3.47

v0.69.x ~ v0.72.3

Due to a bug of rkyv@v0.7.37, you are recommended to use nightly-2022-09-23 as the compiler if you are building a plugin for these targets.

  • @swc/core@1.3.40 ~ @swc/core@1.3.42
  • next@13.2.5-canary.5

v0.66.x ~ v0.68.x

  • @swc/core@1.3.39

v0.61.x ~ v0.64.x

  • @swc/core@1.3.38

v0.54.x ~ v0.59.x

  • @swc/core@1.3.29 ~ @swc/core@1.3.37

  • next@13.2.4-canary.0~

Last updated on May 17, 2023